Amp Free Outage

Incident Report for Amp

Resolved

Amp Free is now operating correctly.
Posted Oct 16, 2025 - 11:24 UTC

Investigating

Amp Free is experiencing an outage. We're investigating and will provide an update soon.
Amp paid usage is unaffected.
Posted Oct 16, 2025 - 10:14 UTC